packages needed by darcs
[archlinuxppc.git] / haskell-hashed-storage / PKGBUILD
diff --git a/haskell-hashed-storage/PKGBUILD b/haskell-hashed-storage/PKGBUILD
new file mode 100644 (file)
index 0000000..438ef5d
--- /dev/null
@@ -0,0 +1,37 @@
+# Maintainer: Vesa Kaihlavirta <vegai@iki.fi>
+# Contributor: Arch Haskell Team <arch-haskell@haskell.org>
+# As generated by cabal2arch 0.7.6
+_hkgname=hashed-storage
+pkgname=haskell-hashed-storage
+pkgver=0.5.3
+pkgrel=1
+pkgdesc="Hashed file storage support code."
+url="http://hackage.haskell.org/package/hashed-storage"
+license=('custom:BSD3')
+arch=('i686' 'x86_64' 'ppc')
+depends=('ghc=6.12.3' 'haskell-binary=0.5.0.2' 'haskell-mmap>=0.5' 'haskell-zlib'  'haskell-mtl' 'haskell-dataenc')
+options=('strip')
+source=(http://hackage.haskell.org/packages/archive/hashed-storage/$pkgver/hashed-storage-$pkgver.tar.gz)
+install=haskell-hashed-storage.install
+md5sums=('84b9fc1b408aee53c5106d9737ca4929')
+
+build() {
+    cd ${srcdir}/hashed-storage-$pkgver
+       ghc --make Setup.hs
+    ./Setup configure --prefix=/usr -p --enable-split-objs --docdir=/usr/share/doc/${pkgname}
+    ./Setup build
+    ./Setup haddock
+    ./Setup register   --gen-script
+    ./Setup unregister --gen-script
+}
+
+package() {
+    cd ${srcdir}/${_hkgname}-${pkgver}
+    install -D -m744 register.sh   ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+    install    -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+    install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+    ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+    ./Setup copy --destdir=${pkgdir}
+    install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+    rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}