so far for ppc
[archlinuxppc.git] / happy / PKGBUILD
diff --git a/happy/PKGBUILD b/happy/PKGBUILD
new file mode 100644 (file)
index 0000000..d537f8a
--- /dev/null
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 88454 2010-08-23 18:41:57Z vesa $
+# Maintainer: simo <simo@archlinux.org>
+# Contributor: Vesa Kaihlavirta <vegai@iki.fi>
+pkgname=happy
+pkgver=1.18.5
+pkgrel=1
+pkgdesc="The Parser Generator for Haskell"
+url="http://www.haskell.org/happy/"
+arch=('i686' 'x86_64' 'ppc')
+license=("custom:BSD3")
+depends=(gmp)
+makedepends=(ghc haskell-mtl)
+options=(strip)
+source=(http://hackage.haskell.org/packages/archive/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz)
+
+
+build() {
+  cd $startdir/src/${pkgname}-${pkgver}
+
+  runhaskell Setup.lhs configure --prefix=/usr || return 1
+  runhaskell Setup.lhs build || return 1
+  runhaskell Setup.lhs copy --destdir=$startdir/pkg || return 1
+
+  install -D -m644 LICENSE $startdir/pkg/usr/share/licenses/$pkgname/LICENSE
+}
+md5sums=('9e77b67df7b6a4d7273383cc890f39e8')