so far for ppc
[archlinuxppc.git] / ghc / PKGBUILD
diff --git a/ghc/PKGBUILD b/ghc/PKGBUILD
new file mode 100644 (file)
index 0000000..0b6daa1
--- /dev/null
@@ -0,0 +1,71 @@
+# $Id: PKGBUILD 87335 2010-08-12 12:32:29Z vesa $
+# Maintainer: Vesa Kaihlavirta <vesa@archlinux.org>
+pkgname=ghc
+pkgver=6.12.3
+pkgrel=1
+pkgdesc="The Glasgow Haskell Compiler"
+arch=(i686 x86_64 ppc)
+url="http://www.haskell.org/ghc/"
+license=("custom")
+depends=('perl' 'gmp>=5.0' gcc)
+makedepends=(perl)
+provides=("haskell-array=0.3.0.1"
+          "haskell-bytestring=0.9.1.7"
+          "haskell-cabal=1.8.0.6"
+          "haskell-containers=0.3.0.0"
+          "haskell-directory=1.0.1.1"       
+          "haskell-extensible-exceptions=0.1.1.1"
+          "haskell-filepath=1.1.0.4"
+          "haskell-haskell98=1.0.1.1"
+          "haskell-hpc=0.5.0.5"
+          "haskell-old-locale=1.0.0.2"
+          "haskell-old-time=1.0.0.5"
+          "haskell-pretty=1.0.1.1"
+          "haskell-process=1.0.1.3"
+          "haskell-random=1.0.0.2"
+          "haskell-syb=0.1.0.2"
+          "haskell-template-haskell=2.4.0.1"
+          "haskell-time=1.1.4"
+          "haskell-unix=2.4.0.2"
+          "haddock=2.6.0"
+         )
+replaces=("haskell-array<0.3.0.1" 
+          "haskell-bytestring<0.9.1.7"
+          "haskell-cabal<1.8.0.6"
+          "haskell-containers<0.3.0.0"
+          "haskell-directory<1.0.1.1"
+          "haskell-extensible-exceptions<0.1.1.1"
+          "haskell-filepath<1.1.0.4"
+          "haskell-haskell98<1.0.1.1"
+          "haskell-hpc<0.5.0.5"
+          "haskell-old-locale<1.0.0.2"
+          "haskell-old-time<1.0.0.5"
+          "haskell-pretty<1.0.1.1"
+          "haskell-process<1.0.1.3"
+          "haskell-random<1.0.0.2"
+          "haskell-syb<0.1.0.2"
+          "haskell-template-haskell<2.4.0.1"
+          "haskell-time<1.1.4"
+          "haskell-unix<2.4.0.2"
+          "haddock<2.6.0"
+         )
+
+backup=(usr/lib/ghc-6.12.3/package.conf)
+install=ghc.install
+
+source=("http://darcs.haskell.org/download/dist/$pkgver/$pkgname-$pkgver-src.tar.bz2" \
+        build.mk)
+
+build() {
+  cd $srcdir/$pkgname-$pkgver
+
+  cp $srcdir/build.mk mk/build.mk
+
+  ./configure --prefix=/usr 
+  make -j1 || return 1
+  make DESTDIR=$pkgdir install
+
+  install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/ghc/license
+}
+md5sums=('4c2663c2eff833d7b9f39ef770eefbd6'
+         '5a3e0880c80b1dcecf779ff2e63a9c0d')